使用rvm在Mac中安装ruby和rails

Posted by Elton's Blog on September 9, 2011

MacOS默认安装的是ruby 1.8.7,如果你想使用ruby 1.9.2的话,除了在官网下载源码编译安装外,可以使用rvm来协助安装。

STEP-1 安装RVM

在Terminal中输入以下命令即可安装

bash < <(curl -s https://rvm.beginrescueend.com/install/rvm)

为了可以在shell中使用,需要在.bash_profile中输入以下命令

cd ~/
sudo vim .bash_profile

#在.bash_profile中加入
[[ -s "$HOME/.rvm/scripts/rvm" ]] &amp;&amp; source "$HOME/.rvm/scripts/rvm"  # This loads RVM into a shell session.

之后退出Terminal,重启它。

STEP-2 安装Ruby

使用以下命令,可以看到rvm可以支持安装的内容

$ rvm list known
# MRI Rubies
1.8.6[-p420]
1.8.6-head
1.8.7[-p352]
1.8.7-head
1.9.1-p378
1.9.1[-p431]
1.9.1-head
1.9.2-p180
1.9.2[-p290]
1.9.2-head
ruby-head
...

使用下面的命令安装ruby 1.9.2

rvm install 1.9.2

然后使用下面命令,让系统使用新的ruby

$rvm use 1.9.2
Using /Users/elton/.rvm/gems/ruby-1.9.2-p290
$ruby -v
ruby 1.9.2p290 (2011-07-09 revision 32553) [x86_64-darwin11.1.0]

当你重启机器后,你会发现又回复成了1.8.7了,可以使用下面命令,让系统默认使用1.9.2

rvm --default use 1.9.2

STEP-3 安装Rails

这步很简单

gem install rails

之后就可以使用最新的ruby和rails了。